分析家公式网,免费股票公式,股票软件下载站 用户登录  |  用户 注册
看盘(大智慧公式 主图 源码 贴图)
  • 软件大小:22.0 KB
  • 推荐星级:
  • 更新时间:2019-03-13 00:48:52
  • 软件类别: 国产软件 / 大智慧L2公式
  • 软件语言:简体中文
  • 授权方式: 免费版
  • 联系方式:暂无联系方式
  • 官方主页: Home Page
  • 点击大图:  【一键转帖到论坛】
  • 插件情况:
  • 运行环境:Win9X/Win2000/WinXP/Win2003/Win7/
  • 相关Tags:看盘  
  • (0)0%
    (0)0%

软件介绍

 

MA5:MA(C,5),PRECIS2,COLORFFFFFF;

MA10:MA(C,10),PRECIS2,COLORYELLOW;

MA20:MA(C,20),PRECIS2,COLORFF68FF;

MA30:MA(C,30),PRECIS2,ColorGREEN; 

MA60:MA(C,60),PRECIS2;{

MA120:MA(C,120),linethick0,PRECIS2;

MA250:MA(C,250),linethick0,PRECIS2;}

均线:(MA(CLOSE,M) * 1),PRECIS2,ColorFFFFFF,DASHLINE;

乖离率:(CLOSE-均线)/均线*100,PRECIS2,linethick0,Color00FFFF;

DRAWTEXT(DISPSTATUS=2,均线,'     '+NUMTOSTRN(M,0)+'日 乖离率: '+NUMTOSTRN(乖离率,2),5),ALIGN0,VALIGN1,ColorFFFFFF;

{CCI}

TYP := (HIGH + LOW + CLOSE)/3;

CCI:(TYP-MA(TYP,CI))/(0.015*AVEDEV(TYP,CI)),PRECIS0,ColorFFFFFF,linethick0;

DRAWGBK(CCI>100),Color00002F;

DRAWGBK(CCI<-100),Color002F00;

{撑压划线}

A1:=ref(h,N)=hhv(h,2*N+1);

B1:=filter(A1,N);

C1:=backset(B1,N+1);

D1:=filter(C1,N);{高点}

A2:=ref(l,N)=llv(l,2*N+1);

B2:=filter(A2,N);

C2:=backset(B2,N+1);

D2:=filter(C2,N);{低点}

E1:=(ref(llv(l,2*N),1)+ref(hhv(h,2*N),1))/2; 

E2:=(h+l)/2;{高低点出现在同一K线上时可作取舍}

H1:=(D1 AND not(D2 AND E1>=E2)) OR barstatus=2 OR barscount(c)=1;

L1:=(D2 AND not(D1 AND E1<E2));

H2:=D1 AND not(D2 AND E1>=E2);

X1:=ref(barslast(H1),1)+1; 

F1:=backset(H1 AND count(L1,X1)>0,llvbars(if(L1,l,10000),X1));

G1:=F1>ref(F1,1);

I1:=backset(G1,2);

LD:=I1>ref(I1,1);{过滤后低点}

L2:=LD OR barstatus=2 OR barscount(c)=1;

X2:=ref(barslast(L2),1)+1; 

F2:=backset(L2 AND count(H2,X2)>0,hhvbars(if(H2,h,0),X2));

G2:=F2>ref(F2,1); 

I2:=backset(G2,2); 

HD:=I2>ref(I2,1);{过滤后高点}

R1:=backset(barstatus=2,barslast(HD)+1); 

S1:=R1>ref(R1,1); {前一高}

T1:=backset(barstatus=2,barslast(LD)+1); 

U1:=T1>ref(T1,1); {前一低}{

{涨跌幅时间窗口}

A:=BARSLAST(DISPSTATUS=1)+1;

HH:=HHV(HIGH,A);

LL:=LLV(LOW,A);

上涨:=BARSSINCE(BACKSET(DISPSTATUS=2,BARSLAST(L=LL)+1));

上涨空间%:=(C/REF(L,上涨)-1)*100;

最高%:=(HHVALL(HH)/REF(L,上涨)-1)*100;

下跌:=BARSSINCE(BACKSET(DISPSTATUS=2,BARSLAST(H=HH)+1));

下跌空间%:=(C/REF(H,下跌)-1)*100;

最低%:=(LLVALL(LL)/REF(H,下跌)-1)*100;

最高价:REF(H,下跌),PRECIS2,COLOR0000FF,DOTLINE;

最低价:REF(L,上涨),PRECIS2,COLOR00FF00,DOTLINE;

幅度:最高价-最低价,PRECIS2,COLORFFFFFF,linethick0;

半分位:=O+(C-O)/2;

昨半分位:REF(半分位,1),PRECIS2,COLOR00FFFF,linethick0;

DRAWTEXT(BARSTATUS=2,昨半分位,'---- 昨半分位:'+NUMTOSTRN(昨半分位,2)+'',-5),ALIGN0,COLOR00FFFF;

DRAWTEXT(BARSTATUS=2,昨半分位,'-------',-5),ALIGN2,COLOR00FFFF;

DRAWTEXT(BARSTATUS=2,最高价,'     最高价:'+NUMTOSTRN(最高价,2),2),ALIGN0,color0000ff;

DRAWTEXT(BARSTATUS=2,最低价,'     最低价:'+NUMTOSTRN(最低价,2),-12),ALIGN0,color00FF00;

drawline(最高价,h,S1,h,1),Color00BBFF,DOTLINE;

drawline(最低价,l,U1,l,1),ColorDFFF08,DOTLINE;

{布林带}

布林中轨:MA(CLOSE,BL),PRECIS2,COLORFFFFFF,DASHLINE;

布林上轨:布林中轨+ P*STD(CLOSE,BL),PRECIS2,COLOR0000FF,DASHLINE;

布林下轨:布林中轨- P*STD(CLOSE,BL),PRECIS2,COLOR00FF00,DASHLINE;

VERTLINE(上涨=0,3),COLOR0000FF;

VERTLINE(下跌=0,3),COLOR00FF00;

DRAWTEXT(上涨=0 AND 最高%>10,LL*1.1,' 10%',-5),COLORYELLOW;

DRAWTEXT(上涨=0 AND 最高%>20,LL*1.2,' 20%',-5),COLOR00FFFF;

DRAWTEXT(上涨=0 AND 最高%>30,LL*1.3,' 30%',-5),COLOR00FFFF;

DRAWTEXT(上涨=0 AND 最高%>40,LL*1.4,' 40%',-5),COLOR00FFFF;

DRAWTEXT(上涨=0 AND 最高%>50,LL*1.5,' 50%',-5),COLOR00FFFF;

DRAWTEXT(上涨=0 AND 最高%>60,LL*1.6,' 60%',-5),COLOR00FFFF;

DRAWTEXT(上涨=0 AND 最高%>70,LL*1.7,' 70%',-5),COLOR00FFFF;

DRAWTEXT(上涨=0 AND 最高%>80,LL*1.8,' 80%',-5),COLOR00FFFF;

DRAWTEXT(上涨=0 AND 最高%>90,LL*1.9,' 90%',-5),COLOR00FFFF;

DRAWTEXT(上涨=0 AND 最高%>100,LL*2,' 100%',-5),COLOR00FFFF;

DRAWTEXT(上涨=0 AND 最高%>125,LL*2.25,' 125%',-5),COLOR00FFFF;

DRAWTEXT(上涨=0 AND 最高%>150,LL*2.5,' 150%',-5),COLOR00FFFF;

DRAWTEXT(上涨=0 AND 最高%>200,LL*3,' 200%',-5),COLOR00FFFF;

DRAWTEXT(上涨=0 AND 最高%>250,LL*3.5,' 250%',-5),COLOR00FFFF;

DRAWTEXT(下跌=0 AND 最低%<-10,HH*0.9,' -10%'),COLORFFFFFF;

DRAWTEXT(下跌=0 AND 最低%<-20,HH*0.8,' -20%'),COLORFFFFFF;

DRAWTEXT(下跌=0 AND 最低%<-30,HH*0.7,' -30%'),COLORFFFFFF;

DRAWTEXT(下跌=0 AND 最低%<-40,HH*0.6,' -40%'),COLORFFFFFF;

DRAWTEXT(下跌=0 AND 最低%<-50,HH*0.5,' -50%'),COLORFFFFFF;

DRAWTEXT(下跌=0 AND 最低%<-60,HH*0.4,' -60%'),COLORFFFFFF;

DRAWTEXT(下跌=0 AND 最低%<-70,HH*0.3,' -70%'),COLORFFFFFF;

DRAWTEXT(下跌=0 AND 最低%<-80,HH*0.2,' -80%'),COLORFFFFFF;

DRAWTEXT(下跌=0 AND 最低%<-90,HH*0.1,' -90%'),COLORFFFFFF;

DRAWTEXT(上涨=5,H,'涨5',-20),COLOR00FFFF,ALIGN1;

DRAWTEXT(上涨=8,H,'涨8',-20),COLOR00FFFF,ALIGN1;

DRAWTEXT(上涨=13,H,'涨13',-20),COLOR00FFFF,ALIGN1;

DRAWTEXT(上涨=21,H,'涨21',-20),COLOR00FFFF,ALIGN1;

DRAWTEXT(上涨=34,H,'涨34',-20),COLOR00FFFF,ALIGN1;

DRAWTEXT(上涨=55,H,'涨55',-20),COLOR00FFFF,ALIGN1;

DRAWTEXT(上涨=89,H,'涨89',-20),COLOR00FFFF,ALIGN1;

DRAWTEXT(上涨=144,H,'涨144',-20),COLOR00FFFF,ALIGN1;

DRAWTEXT(上涨=180,H,'涨180',-20),COLOR00FFFF,ALIGN1;

DRAWTEXT(上涨=250,H,'涨250',-20),COLOR00FFFF,ALIGN1;

DRAWTEXT(下跌=5,L,'跌5',10),COLOR00FF00,ALIGN1;

DRAWTEXT(下跌=8,L,'跌8',10),COLOR00FF00,ALIGN1;

DRAWTEXT(下跌=13,L,'跌13',10),COLOR00FF00,ALIGN1;

DRAWTEXT(下跌=21,L,'跌21',10),COLOR00FF00,ALIGN1;

DRAWTEXT(下跌=34,L,'跌34',10),COLOR00FF00,ALIGN1;

DRAWTEXT(下跌=55,L,'跌55',10),COLOR00FF00,ALIGN1;

DRAWTEXT(下跌=89,L,'跌89',10),COLOR00FF00,ALIGN1;

DRAWTEXT(下跌=144,L,'跌144',10),COLOR00FF00,ALIGN1;

DRAWTEXT(下跌=180,L,'跌180',10),COLOR00FF00,ALIGN1;

DRAWTEXT(下跌=250,L,'跌250',10),COLOR00FF00,ALIGN1;

{百分指标}{

bb146:最低价+幅度*0.146,DOTLINE;

bb236:最低价+幅度*0.236,DOTLINE;

BB382:最低价+幅度*0.382,DOTLINE;

BB50:最低价+幅度*0.5,DOTLINE;

BB618:最低价+幅度*0.618,DOTLINE;

BB854:最低价+幅度*0.854,DOTLINE;

DRAWTEXT(BARSTATUS=2,bb146,'     0.146%:'+NUMTOSTRN(bb146,2),-5),ALIGN0,color00FFff;

DRAWTEXT(BARSTATUS=2,bb236,'     0.236%:'+NUMTOSTRN(bb236,2),-5),ALIGN0,color00FFff;

DRAWTEXT(BARSTATUS=2,bb382,'     0.382%:'+NUMTOSTRN(bb382,2),-5),ALIGN0,color00FFff;

DRAWTEXT(BARSTATUS=2,bb50,'     0.5%:'+NUMTOSTRN(bb50,2),-5),ALIGN0,COLORMAGENTA;

DRAWTEXT(BARSTATUS=2,bb618,'     0.618%:'+NUMTOSTRN(bb618,2),-5),ALIGN0,COLOR00FFFF;

DRAWTEXT(BARSTATUS=2,bb854,'     0.854%:'+NUMTOSTRN(bb854,2),-5),ALIGN0,color00FFff;

{K线}

STICKLINE(CLOSE>=OPEN and OPEN<>0,HIGH,LOW,1,0),Color0022FF;

STICKLINE(CLOSE>=OPEN and OPEN<>0,CLOSE,OPEN,7.5,0),color000033;

STICKLINE(CLOSE>=OPEN and OPEN<>0,CLOSE,OPEN,6,0),color000066;

STICKLINE(CLOSE>=OPEN and OPEN<>0,CLOSE,OPEN,5,0),color000088;

STICKLINE(CLOSE>=OPEN and OPEN<>0,CLOSE,OPEN,4,0),color0000BB;

STICKLINE(CLOSE>=OPEN and OPEN<>0,CLOSE,OPEN,2.5,0),Color0000EE;

STICKLINE(CLOSE>=OPEN and OPEN<>0,CLOSE,OPEN,1,0),Color0022FF;

STICKLINE(CLOSE<OPEN and OPEN<>0,HIGH,LOW,1,0),Color00FF00;

STICKLINE(CLOSE<OPEN and OPEN<>0,CLOSE,OPEN,7.5,0),Color003300;

STICKLINE(CLOSE<OPEN and OPEN<>0,CLOSE,OPEN,6,0),Color006600;

STICKLINE(CLOSE<OPEN and OPEN<>0,CLOSE,OPEN,5,0),Color008800;

STICKLINE(CLOSE<OPEN and OPEN<>0,CLOSE,OPEN,4,0),Color00BB00;

STICKLINE(CLOSE<OPEN and OPEN<>0,CLOSE,OPEN,2.5,0),Color00EE00;

STICKLINE(CLOSE<OPEN and OPEN<>0,CLOSE,OPEN,1,0),Color00FF00;

{向下跳空缺口}

I3:=0;

FLAG1:=0;

while I3<BARSLAST(DISPSTATUS=1)-BARSLAST(DISPSTATUS=2) DO  

IF REF(H,I3)<REF(L,I3+1) AND REF(L,I3+1)>HHV(H,I3+1) THEN   BEGIN     

FLAG1:=1;

S3:=I3;

I3:=BARSLAST(DISPSTATUS=1); END ELSE  

I3:=I3+1;            

STICKLINE(FLAG1,REF(L,S3+1),HHV(H,S3+1),(s3+1)*20,0),ColorC0C0C0,ALIGN0,LAYER7;

DRAWTEXT(FLAG1,REF(L,s3+1),'     向下跳空:'+NUMTOSTRN(ref(L,s3+1),2)+'-'+NUMTOSTRN(hhV(h,S3+1),2),-12),ALIGN0,COLOR00FF00;

{向上跳空缺口}

I:=0;

FLAG:=0;

while I<BARSLAST(DISPSTATUS=1)-BARSLAST(DISPSTATUS=2) DO  

IF REF(L,I)>REF(H,I+1) AND REF(H,I+1)<LLV(LOW,I+1) THEN   BEGIN     

FLAG:=1;

S:=I;

I:=BARSLAST(DISPSTATUS=1); END  ELSE  

I:=I+1;            

STICKLINE(FLAG,REF(h,S+1),LLV(LOW,S+1),20*(s+1),500),ColorC0C0C0,ALIGN1,LAYER7;

DRAWTEXT(FLAG,REF(H,s+1),'     向上跳空:'+NUMTOSTRN(ref(h,s+1),2)+'-'+NUMTOSTRN(LLV(LOW,S+1),2),2),ALIGN0,COLOR0000FF;

DRAWTEXTABS(0,0,'《夏卫东-自编》'),COLOR0000FF;

下载地址(点击下图进入下载地址网页)

    看盘(大智慧公式 主图 源码 贴图)下载

软件评论评论内容只代表网友观点,与本站立场无关!

   评论摘要(共 0 条,得分 0 分,平均 0 分) 查看完整评论

下载说明

* 下载方法:点击上面的绿色图片(图片有“下载地址”文字),就新开一个页面,点击“本地高速下载”,或者点击文字“下载地址1”即可下载软件

* 本网站提供各类股票软件(大智慧股票软件 股票软件哪个好 股票软件下载 通达信股票软件 同花顺软件 飞狐软件 文华软件 期货软件 手机炒股软件 指南针股票软件 东方财富通)和各种股票软件公式指标(大智慧公式 通达信公式 同花顺公式 操盘手公式 文华公式 飞狐公式 等等股票公式 股票价格计算公式 股票公式网 股票公式大全 股票公式论坛),还有各类股票书籍(股票入门书籍下载 股票书籍下载 股票书籍免费下载),都网上搜集转载可以免费下载
* 请一定升级到最新版WinRAR才能正常解压本站提供的软件!

本网提供的公式文件说明:
* alg格式股票公式,仅仅可以用飞狐交易师股票软件引入使用;
* fnc格式股票公式,可以用大智慧新一代高速行情分析系统股票软件使用,少部分可以用分析家股票软件引入使用;
* exp格式股票公式,仅可以用大智慧经典版股票软件引入使用;
* tnc和tni格式股票公式,仅可以用通达信新引入使用,例如可以用通达信股票软件引入使用;
* tne,tn6格式公式,可以用通达信公式编辑器5.0版导入,推荐通达信短线极品版本;
* hxf格式股票公式,仅可以用同花顺股票软件引入使用。
以上的各种软件都可以在本网股票软件栏目找到并下载!

* 关于股票公式时间限制,如果在引入大智慧公式,交易师公式或者飞狐公式的时候,发现公式名称栏是空白的,这时候调整电脑时间到1997年,又能出现公式名称 ,并且能正常显示,可能是公式使用期限已过。
* 关于公式解密收费解密大智慧公式(FNC格式)大智慧股票池,同花顺公式(hxf格式),操盘手公式(daf),飞狐公式(alg),博易大师公式,文华公式等等源码,可解密完全加密定向加密公式或延时,收费服务无意勿扰,联系QQ984388831。

* 关于股票公式源码编辑
本网提供的源码,一般都可以编辑成公式,如果不明白公式的编辑,在本页右侧教程录像可参考,或者找公式教程资料学习,请搜索:教程

* 如果您发现下载链接错误,请点击报告错误谢谢!
* 站内提供的所有软件包含和谐及注册码均是由网上搜集,若侵犯了你的版权利益,敬请来信通知我们!

关于本站 | 网站帮助 | 广告合作 | 下载声明 | 友情连接 | 网站地图 |

声明:本站所有软件和信息均免费。站内所有广告,如有收费行为,均与本站无任何关系!请广大网友小心谨慎。
Copyright © 2003-2008 88GS.Com. All Rights Reserved .
页面执行时间:5,296.87500 毫秒